

<!DOCTYPE html>

<html lang="en" xmlns:og="http://opengraphprotocol.org/schema/">

<head> 

  <meta charset="utf-8">

  <meta name="viewport" content="width=device-width, initial-scale=1">

  <meta http-equiv="Content-Type" content="text/html">

  <title>Obituary: Ben C. Allen Jr. | The Verde Independent | Cottonwood, AZ</title>

  

  

  

  <meta property="fb:app_id" content="402950826772574"/> 

  <meta property="og:title" content="Obituary: Ben C. Allen Jr.">

  <meta property="og:type" content="article">

  <meta property="og:url" content="https://www.verdenews.com/news/2022/apr/24/obituary-ben-c-allen-jr/">

   

    <meta property="og:description" content="Ben C. Allen Jr., (Benny), 65, of Cottonwood, Arizona, passed away peacefully with close family by his side on Tuesday, April 19, 2022. He was born in Cottonwood, Arizona, on August 28, 1956 to the late Ben C. Allen Sr. and Sylvia May Allen">

   

  

  <meta property="og:image" content="https://westernnews.media.clients.ellingtoncms.com/img/photos/2022/04/24/Ben_C._Allen_Jr._obit_photo_VVN_Sun_4-24-22_WEB.jpg" />

  

  <meta property="og:site_name" content="Verde Independent">

  <meta name="twitter:title" content="Obituary: Ben C. Allen Jr.">

  

  <meta name="twitter:card" content="summary_large_image">

  <meta name="twitter:site" content="@www.verdenews.com">

  <meta name="twitter:image" content="https://westernnews.media.clients.ellingtoncms.com/img/photos/2022/04/24/Ben_C._Allen_Jr._obit_photo_VVN_Sun_4-24-22_WEB.jpg">

  

  

  <meta name="twitter:description" content="Ben C. Allen Jr., (Benny), 65, of Cottonwood, Arizona, passed away peacefully with close family by his side on Tuesday, April 19, 2022. He was born in Cottonwood, Arizona, on August 28, 1956 to the late Ben C. Allen Sr. and Sylvia May Allen">

  

  <meta name="twitter:widgets:csp" content="on">



  

  <link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/print.css?v=18" type="text/css" media="print">

  <link  href="https://westernnews.media.clients.ellingtoncms.com/static-3/vendors/datepicker/datepicker.min.css" rel="stylesheet">

  <!--[if IE 6]><link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/stylesheets/ie6.css" type="text/css" media="screen"><![endif]-->

  <!--[if IE 7]><link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/stylesheets/ie7.css" type="text/css" media="screen"><![endif]-->

<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.4.1/semantic.min.css">


<link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/dist/css/main.min.css?v=326" type="text/css">
<link rel="stylesheet" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/froala_style.min.css" type="text/css">



<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/1.12.0/jquery.min.js" integrity="sha256-Xxq2X+KtazgaGuA2cWR1v3jJsuMJUozyIXDB3e793L8=" crossorigin="anonymous"></script>



  

  <link rel="icon" type="image/x-icon" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/verdenews/logos/favicon.ico" sizes="32x32">

  <link rel="icon" type="image/png" href="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/verdenews/logos/favicon.png" sizes="32x32">



  <script type="text/javascript">

    var STATIC_MEDIA_URL = 'https://westernnews.media.clients.ellingtoncms.com/static-3/';

  </script>

  <script src="https://polyfill.io/v2/polyfill.min.js?features=IntersectionObserver"></script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/lozad.min.js"></script>

  <script src="https://cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.4.1/semantic.min.js"></script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/ellington_defaults/2.3.0/javascript/lib/cookies.js"></script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/js-cookie.js"></script>

  <script type="text/javascript" src="https://maps.googleapis.com/maps/api/js?key=AIzaSyAPfAD5-v4cObqJcVA7x5izMVPKJ-Q-qds" ></script>

  

<script>

  var syncPaymeter = {

    onLoad: function(meter){

      meter.events.registerHandler(meter.events.onAuthorizeSuccess,

        function(ctx){

          // document.getElementById('paywall-loader').style.display = 'none';

          document.getElementById('flipp-overlay').style.display = 'none';

          // document.querySelector('.story_body').style.display = 'block';

          document.getElementById('circularhub_module_2880').style.display = 'block';

          console.log('++++++++++++++++++++++ Authorization Success'); 

        });

      meter.events.registerHandler(meter.events.onWallFired,

        function(ctx){

          // document.getElementById('paywall-loader').style.display = 'none';

          console.log('++++++++++++++++++++++ Wall Fired');

        });

      meter.events.registerHandler(meter.events.onSessionStarting,

        function(ctx){

          // document.getElementById('sync-inline-overlay').style.display = 'block';

          console.log('++++++++++++++++++++++ Session Starting');

        });

      meter.events.registerHandler(meter.events.onSessionStarted,

        function(ctx){

          console.log('++++++++++++++++++++++ Session Started');

        });

      meter.events.registerHandler(meter.events.onSessionSaving,

        function(ctx){

          console.log('++++++++++++++++++++++ Session Saving');

        });

      meter.events.registerHandler(meter.events.onSessionSaved,

        function(ctx){

          console.log('++++++++++++++++++++++ Session Saved');

        });

      meter.events.registerHandler(meter.events.onAuthorizeStarting,

        function(ctx){

          console.log('++++++++++++++++++++++ Authorization Starting');

        });

      meter.events.registerHandler(meter.events.onAuthorizeFailed,

        function(ctx){

          // document.getElementById('sync-inline-overlay').style.display = 'block';

          console.log('++++++++++++++++++++++ Authorization FAILED');

        });

      meter.events.registerHandler(meter.events.onServerError,

        function(ctx){

          console.log('++++++++++++++++++++++ SERVER ERROR');

        });

    }

  };

</script>

 



  <script src="https://westernnews.media.clients.ellingtoncms.com/static-3/vendors/datepicker/datepicker.min.js"></script>

  <script src="https://westernnews.media.clients.ellingtoncms.com/static-3/vendors/momentjs/moment.min.js"></script>

  <script type="text/javascript" async="async" src="//widgets.outbrain.com/outbrain.js"></script>

  

  <link type="application/rss+xml" rel="alternate" href="/rss/headlines/">

  

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>

<script>

  var googletag = googletag || {};

  googletag.cmd = googletag.cmd || [];

</script>

  

 <script>      

  googletag.cmd.push(function() {

    var desktopMapping = googletag.sizeMapping().

      addSize([768, 0], [[1400, 400],[1278, 900],[1200, 628],[989, 150], [728,90], [300, 600], [300, 250]]).

      addSize([0, 0], []).

      build();

    var mobileMapping = googletag.sizeMapping().

      addSize([768, 0], []).

      addSize([0, 0], [[320, 50], [300, 250], [310, 310]]).

      build();

    googletag.defineSlot('/34608832/vvn_lb_atf', [[728, 90], [989, 150]], 'div-gpt-ad-1551977883160-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/34608832/vn_hp_top_leaderboard', [[728, 90], [989, 150]], 'div-gpt-ad-1552072407498-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/34608832/vvn_lb_btf', [[989, 150], [728, 90]], 'div-gpt-ad-1551978476607-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    adSlot1 = googletag.defineSlot('/34608832/vvn_rr_1', [[300, 600], [300, 250]], 'div-gpt-ad-1551979025902-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    adSlot2 = googletag.defineSlot('/34608832/vvn_rr_2', [[300, 600], [300, 250]], 'div-gpt-ad-1551979085261-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    adSlot3 = googletag.defineSlot('/34608832/vvn_rr_3', [[300, 250], [300, 600]], 'div-gpt-ad-1551979126339-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/34608832/homepage_above_all_content', [[989, 150], [1200, 628], [1400, 400], [728, 90], [989, 250], [1278, 900]], 'div-gpt-ad-1626132751343-0').defineSizeMapping(desktopMapping).addService(googletag.pubads());

    googletag.defineSlot('/34608832/vn_hp_medrec_1', [300, 250], 'div-gpt-ad-1551979175359-0').addService(googletag.pubads());

    googletag.defineSlot('/34608832/vn_hp_medrec_2', [300, 250], 'div-gpt-ad-1551979208698-0').addService(googletag.pubads());

    googletag.defineSlot('/34608832/vvn_non_rotating3', [300, 100], 'div-gpt-ad-1551978966166-0').addService(googletag.pubads());

    googletag.defineSlot('/34608832/vvn_mb', [[320, 50], [300, 250]], 'div-gpt-ad-1598304773433-0').defineSizeMapping(mobileMapping).addService(googletag.pubads());

    googletag.defineSlot('/34608832/vn_mb_footer', [[320, 50], [300, 250]], 'div-gpt-ad-1551978748390-0').defineSizeMapping(mobileMapping).addService(googletag.pubads());

    googletag.defineSlot('/34608832/homepage_above_all_content_mobile', [300, 250], 'div-gpt-ad-1607704040767-0').defineSizeMapping(mobileMapping).addService(googletag.pubads());

    googletag.defineSlot('/34608832/vvn_mb_footer', [310, 310], 'div-gpt-ad-1551978811211-0').defineSizeMapping(mobileMapping).addService(googletag.pubads());

    googletag.defineSlot('/34608832/vvn_mb_ict', [300, 250], 'div-gpt-ad-1551978881566-0').defineSizeMapping(mobileMapping).addService(googletag.pubads());

    googletag.defineSlot('/34608832/Special-Temporary', [1368, 100], 'div-gpt-ad-1590094035925-0').addService(googletag.pubads());

    googletag.pubads().collapseEmptyDivs(true);

    googletag.enableServices();

  });

  

  </script>



  

  

  

</head>

<body class="news story_detail revision" id="story_308014">

  <div class="ui top sidebar vertical menu top-more-menu">

    

  <div class="ui centered aligned page grid">

  <div class="one column row">

    <div class="sixteen wide column"></div>

  </div>

  <div class="five column row">

    <div class="column">

      <div class="item">

        <div class="header">OFFERS</div>

      </div>

      <a class="item top-more-menu-item" target="_blank" href="http://www.smartsource.com">Smart Source Coupons</a>

      <a class="item top-more-menu-item" href="/smartshopper/">Local Smart Shopper</a>

      

      <a class="item top-more-menu-item" target="_blank" href="http://www.928medialab.com">928 Media Lab</a>

    </div>

    <div class="column">

      <div class="item">

        <div class="header">SUBMISSIONS</div>

      </div>

      <a class="item top-more-menu-item" href="/submit/">General Submissions</a>

      <a class="item top-more-menu-item" href="/place-classified-ad/">Place an Ad</a>

      <a class="item top-more-menu-item" href="/subscriber-services/temporary-start-stop/">Subscriber Services (Start / Stop)</a>

    </div>

    <div class="column">

      <div class="item">

        <div class="header">MEDIA</div>

      </div>

      <a class="item top-more-menu-item" href="/users/newsletters-vi/">Receive e-News Alerts</a>

      <a class="item top-more-menu-item" href="/other-publications/">Other Publications</a>

      <a class="item top-more-menu-item" href="/photos/galleries/">Photo Galleries</a>

      <a class="item top-more-menu-item" href="/news/special-sections/">Special Sections</a>

      <a class="item top-more-menu-item" href="/state-archives/">State Archives</a>

    </div>

    <div class="column">

      <div class="item">

        <div class="header">COMMUNITY</div>

      </div>

      <a class="item top-more-menu-item" href="/about/">About Us</a>

      <a class="item top-more-menu-item" href="/classifieds/category/public-notices/">Public Notices</a>

      <a class="item top-more-menu-item" href="/places/churches/all/">Worship Directory</a>

    </div>

    <div class="column">

      <a href="/e-edition/" class="item"><div class="ui positive button">e-Edition</div></a>

      <div class="ui form">

        <form action="/search/" method="get" class="ui icon input"  autocomplete="off" _lpchecked="1">

          <input type="text" name="q" placeholder="Search..." value="">

          <i class="search icon"></i>

        </form>

      </div>

    </div>

  </div>

  <div class="one column row">

    <div class="sixteen wide column"></div>

  </div>

</div>



  </div>

  <div class="ui left vertical inverted menu sidebar sidebar-nav">

    

  <div class="item">

  <a href="/news/latest-news/" class="header">NEWS</a>

  <div class="menu">

    <a class="item" href="/news/latest-news/">Local</a>

    <a href="/news/state/" class="item">State</a>

    <a href="/news/camp-verde-bugle/" class="item">CV Bugle</a>

  </div>

</div>

<div class="item">

  <a href="/news/opinion/" class="header">OPINION</a>

  <div class="menu">

    <a class="item" href="/news/opinion/editorials/">Editorials</a>

    <a class="item" href="/news/opinion/letters/">Letters</a>

    <a class="item" href="/news/opinion/commentary/">Commentary</a>

    <a class="item" href="/news/opinion/rants-raves/">Rants &amp; Raves</a>

  </div>

</div>

<div class="item">

  <a href="/news/sports/" class="header">SPORTS</a>

</div>

<div class="item">

  <a href="/news/celebrate/" class="header">CELEBRATE</a>

</div>

<div class="item">

  <a href="/news/kudos/" class="header">KUDOS</a>

  <div class="menu">

    <a class="item" href="/news/kudos/art/">Art</a>

    <a class="item" href="/news/kudos/nightlife/">Nightlife</a>

    <a class="item" href="/news/kudos/see-do/">See &amp; Do</a>

    <a class="item" href="/news/kudos/music/">Music</a>

    <a class="item" href="/news/kudos/movies/">Movies</a>

    <a class="item" href="/news/kudos/books/">Books</a>

  </div>

</div>

<div class="item">

  <a href="/news/features/" class="header">FEATURES</a>

  <div class="menu">

    

    <a class="item" href="/news/features/business-economy">Business &amp; Economy</a>

    <a class="item" href="/categories/news/features/whats-happening/">What's Happening</a>

    <a class="item" href="/news/features/outdoors/">Outdoors</a>

  </div>

</div>

<div class="item">

  <a href="/news/villager/" class="header">VILLAGER</a>

</div>

<div class="item">

  <a href="/news/obituaries/" class="header">OBITUARIES</a>

</div>

<div class="item">

  <a href="/classifieds/" class="header">CLASSIFIEDS</a>

</div>

<div class="item">

  <a href="/contact-us/" class="header">CONTACT</a>

</div>

<div class="item">

  <a href="/e-edition/" class="header">E-EDITION</a>

</div>

<div class="item">

  <div class="header">MORE</div>

    <div class="menu">

      <a class="item top-more-menu-item" href="/about/">About Us</a>

      <a class="item top-more-menu-item" target="_blank" href="http://www.smartsource.com">Smart Source Coupons</a>

      <a class="item top-more-menu-item" href="/smartshopper/">Local Smart Shopper</a>

      

      <a class="item top-more-menu-item" target="_blank" href="http://www.928medialab.com">928 Media Lab</a>

      <a class="item top-more-menu-item" href="/submit/">General Submissions</a>

      <a class="item" href="/place-classified-ad/">Place an Ad</a>

      <a class="item" href="/subscriber-services/temporary-start-stopstart/">Home Delivery Temporary Stop</a>

      <a class="item" href="/subscriber-services/index/">Subscribe and Subscriber Services</a>

      <a class="item top-more-menu-item" href="/users/newsletters-vi/">Newsletter</a>

      <a class="item top-more-menu-item" href="/other-publications/">Other Publications</a>

      <a class="item top-more-menu-item" href="/photos/galleries/">Photo Galleries</a>

      <a class="item top-more-menu-item" href="/news/special-sections/">Special Sections</a>

      <a class="item top-more-menu-item" href="/state-archives/">State Archives</a>

      <a class="item top-more-menu-item" href="/classifieds/category/public-notices/">Public Notices</a>

      <a class="item top-more-menu-item" href="/places/churches/all/">Worship Directory</a>      

    </div>

</div>
 



  </div>

  <div class="pusher">

    

    <script>

      dataLayer = [];

      var observer = lozad('.lozad', {

        rootMargin: '500px 0px',

        threshold: 0.1

      });

    </script>

    

  

    

      

          

            <script>

              var category = 'Obituaries';

              dataLayer.push({

                'contentGroup1': category,

                'dimension1': category

              });

           </script>

          

      

    





    

  <!-- Google Tag Manager -->

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':

new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],

j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=

'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);

})(window,document,'script','dataLayer','GTM-KMJHS4');</script>

<!-- End Google Tag Manager -->

 

    

  <script type="text/javascript">

(function() {

  var ARTICLE_URL = window.location.href;

  var CONTENT_ID = 'everything';

  document.write(

    '<scr'+'ipt '+

    'src="//survey.g.doubleclick.net/survey?site=_nvxbjsxm5gzvpph7blw7of5xou'+

    '&amp;url='+encodeURIComponent(ARTICLE_URL)+

    (CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+

    '&amp;random='+(new Date).getTime()+

    '" type="text/javascript">'+'\x3C/scr'+'ipt>');

})();

</script>



    

<script>

  window.fbAsyncInit = function() {

    FB.init({

      appId      : '402950826772574',

      xfbml      : true,

      version    : 'v2.9'

    });

    FB.AppEvents.logPageView();

  };

  (function(d, s, id){

     var js, fjs = d.getElementsByTagName(s)[0];

     if (d.getElementById(id)) {return;}

     js = d.createElement(s); js.id = id;

     js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.9&appId=402950826772574";

     fjs.parentNode.insertBefore(js, fjs);

   }(document, 'script', 'facebook-jssdk'));

</script>



    

  <div id="main-navigation" class="ui inverted menu no-margin verdenews">



  <div class="ui container inverted menu borderless main-nav-items verdenews">

    <a href="/" class="item" id="navbar-logo-link">

      <img src="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/verdenews/logos/nav-bar-logo-ball.png" alt="verde news logo" class="ui image small" id="navbar-logo">

    </a>

    <div class="ui simple dropdown item hide-main-nav">

      <a href="/news/latest-news/">NEWS</a>

      <div class="menu">

        <a class="item" href="/news/latest-news/">Local</a>

        <a href="/news/state/" class="item">State</a>

        <a href="/news/camp-verde-bugle/" class="item">CV Bugle</a>

      </div>

    </div>

    <div class="ui simple dropdown item hide-main-nav">

      <a href="/news/opinion/">OPINION</a>

      <div class="menu">

        <a class="item" href="/news/opinion/editorials/">Editorials</a>

        <a class="item" href="/news/opinion/letters/">Letters</a>

        <a class="item" href="/news/opinion/commentary/">Commentary</a>

        <a class="item" href="/news/opinion/rants-raves/">Rants &amp; Raves</a>

      </div>

    </div>

    <a href="/news/sports/" class="item hide-main-nav">SPORTS</a>

    <div class="ui simple dropdown item hide-main-nav">

      <a href="/news/kudos/">KUDOS</a>

      <div class="menu">

        <a class="item" href="/news/kudos/art/">Art</a>

        <a class="item" href="/news/kudos/nightlife/">Nightlife</a>

        <a class="item" href="/news/kudos/see-do/">See &amp; Do</a>

        <a class="item" href="/news/kudos/music/">Music</a>

        <a class="item" href="/news/kudos/movies/">Movies</a>

        <a class="item" href="/news/kudos/books/">Books</a>

      </div>

    </div>

    <a href="/news/villager/" class="item hide-main-nav">VILLAGER</a>

    <div class="ui simple dropdown item hide-main-nav">

      <a href="/news/features/">FEATURES</a>

      <div class="menu">

        

        <a class="item" href="/news/features/business-economy">Business &amp; Economy</a>

        <a class="item" href="/categories/news/features/whats-happening/">What's Happening</a>

        <a class="item" href="/news/features/outdoors/">Outdoors</a>

      </div>

    </div>

    <a href="/news/obituaries/" class="item hide-main-nav">OBITUARIES</a>

    <a href="/classifieds/" class="item hide-main-nav">CLASSIFIEDS</a>

    <div class="item menu dropdown more-menu hide-main-nav">MORE <i class="dropdown icon"></i></div>

    <div id="nav-search-trigger" class="item menu dropdown">

      <i class="inverted search icon"></i>

    </div>

    <div id="navbar-search" class="ui form">

      <form action="/search/vertical/news.story/" method="get" autocomplete="off" id="search-form">

        <div class="ui icon input">

          <input type="text" name="q" value="" id="nav-search-input" class="nav-search-input" placeholder="Search...">

            <i class="circular search link icon"></i>

        </div>

      </form>

    </div>

    <script>

      var form = document.getElementById('search-form');

      form.addEventListener('submit', function(e) {

        e.preventDefault();

        var input = document.getElementById('nav-search-input');

        var sort = input.value + '&sortby=date';

        window.location = "/search/vertical/news.story/?q=" + sort;

      });

    </script>

  <div class="ui simple dropdown item">

    <a id="sync-login-status" class="log-in" href="https://subscribe.verdenews.com/Wn/vvn/Account/LogOn?ReturnUrl=https://verdenews.com/news/2022/apr/24/obituary-ben-c-allen-jr/"></a>

    <a id="sync-login-myaccount" href="https://iservicescirc.westernnews.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=vvn"></a>

      <div class="ui inverted menu" id="logoutContainer">

        <div class="item">

          <div id="btnLogout" class="ui negative button">Log Out</div>

        </div>

      </div>

  </div>

    <div id="side-nav-button" class="ui simple dropdown item show-side-nav-button">

      <i class="sidebar icon"></i>

      Menu

    </div>

  </div>

</div>

<script>

  var search = document.getElementById('nav-search-trigger');

  var form =  document.getElementById('navbar-search');

  var input = document.getElementById('nav-search-input');

  search.addEventListener('click', function(e) {

    form.style.zIndex = 1;

    input.classList.toggle('nav-search-animation');

    input.focus();

  });

  input.addEventListener('blur', function(e) {

    this.classList.remove('nav-search-animation');

    form.style.zIndex = -1;

  });

</script> 

 



    <div id="page" class="ui container">

      

      

<div id="mobile-subscribe" class="has-text-centered is-shown-mobile top-margin-one-rem">

  <a href="https://subscribe.verdenews.com/Wn/Vvn/Account/AvailableSubscriptions"><h3 class="ui blue header">Subscribe Now</h3></a>

</div>

<div class="brand-header is-hidden-mobile flex items-center justify-between">

  

  <a href="/">

    <div class="brand-main-logo">

      <embed  style="width:500px; pointer-events: none;" src="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/verdenews/logos/new-logo2.png" alt="The Verde Independent and Camp Verde Bugle Logo">

    </div>

  </a>

  

  

  <div class="has-text-centered">

    <a href="https://subscribe.verdenews.com/Wn/Vvn/Account/AvailableSubscriptions" class="inline-block right-margin-one-rem hidden" id="subscribe-now">

    <div class="has-text-centered">

      <span class="ui blue header">Subscribe Now</span><br>

    </div>

    </a> 

    

      <a href="/e-edition/"><button class="ui basic primary button e-edition-button">e-Edition</button></a>

    

  </div>

  

</div>

<div class="toolbar-header is-hidden-mobile flex justify-between items-center">

  <div class="toolbar-item hide-toolbar-item-medium">

    TRUSTED NEWS LEADER FOR COTTONWOOD, CAMP VERDE &amp; THE VERDE VALLEY

  </div>

  <span class="item-divider hide-toolbar-item-medium"></span>

  <div class="toolbar-item">

    Mon, April 25

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    

     <a href="/weather/">Weather </a>

    

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    <a href="/subscriber-services/index/">Subscriber Services</a>

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    <a href="/contact/">News Tips</a>

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    <a href="/contact-us/">Contact Us</a>

  </div>

  <span class="item-divider"></span>

  <div class="toolbar-item">

    <a href="https://www.facebook.com/verdenews/">  <i class="large facebook icon" aria-hidden="true"></i></a>

  </div>

  <div class="toolbar-item">

    <a href="https://twitter.com/verdenews"> <i class="large twitter square icon" aria-hidden="true"></i></a>

  </div>

  <div class="toolbar-item">

    <a href="https://www.youtube.com/user/verdenews/videos"> <i class="large youtube square icon" aria-hidden="true"></i></a>

  </div>

</div>



      

      

      <div class="breadcrumbs">

        

      </div>

      

      <div id="body">

        <div class="wrapper">

          

            

            

            

            

              <div class="content_title">

                



              </div>

            

            

            

            

              

              <div class="page-content">

                

                

                  

                    

                  

                

                




  

    

      

          

            <script>

              var category = 'Obituaries';

              dataLayer.push({

                'contentGroup1': category,

                'dimension1': category

              });

           </script>

          

      

    





<div class="story">

  <div class="ui equal width grid">

    <div class="column story-column ">

      <div class="ui text container">

        

          <h1 class="ui medium header">

          Obituary: Ben C. Allen Jr.

          

          </h1>

        

        

        

          <div class="story__lead-photo">

            <div class="ui bottom attached segment">

              <div class="photo">

                

                <a href="/photos/2022/apr/24/219792/"><img src="https://westernnews.media.clients.ellingtoncms.com/img/photos/2022/04/24/Ben_C._Allen_Jr._obit_photo_VVN_Sun_4-24-22_WEB_t715.jpg?529764a1de2bdd0f74a9fb4f856b01a9d617b3e9" alt="Ben C. Allen Jr." class="img-responsive"></a>

                

              </div>

              <div class="lead-photo-info">

                

                <p class="caption">

                  Ben C. Allen Jr.

                </p>

              </div>

            </div>

          </div>

        

        

        <div class="article-info">

          



<div class="has-text-centered">



    



</div>



<div class="has-text-centered article-info__item">



  



    



  



  



</div>



<div class="has-text-centered article-info__item">



  <div class="article-published">Originally Published: April 24, 2022 3:16 p.m.</div>



  



    <p class="article-published">



      



    </p>



  



</div>



<div class="flex justify-center items-center">



  <div class="sharing-icon fb-share-button" data-href="https://verdenews.com/news/2022/apr/24/obituary-ben-c-allen-jr/" data-layout="button"></div>



  <div class="sharing-icon troublemaker-sharing-icon"><a class="twitter-share-button" href="https://twitter.com/intent/tweet">Tweet</a><script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script></div>



  <div class="sharing-icon" onclick="window.print()"><i class="print icon print-icon troublemaker-sharing-icon"></i></div>



  <div class="sharing-icon"><a href="mailto:?subject=Obituary: Ben C. Allen Jr.&body=https://verdenews.com/news/2022/apr/24/obituary-ben-c-allen-jr/"><i class="envelope outline icon troublemaker-sharing-icon"></i></a></div>



</div>



        </div>

        <div class="ui divider less-margin"></div>

        

        

        <div id="overlay">

          <div id="overlay-content">

            <div id='sync-inline-overlay'>

              <div class="story_body fr-view" id="target-story_body_template" >

                

                <p>Ben C. Allen Jr.</p>

<p>1956 - 2022</p>

<p>Ben C. Allen Jr., (Benny), 65, of Cottonwood, Arizona, passed away peacefully with close family by his side on Tuesday, April 19, 2022. He was born in Cottonwood, Arizona, on August 28, 1956 to the late Ben C. Allen Sr. and Sylvia May Allen.<br/>
<br/>
</p>

<p>Ben had a passion for being outdoors, hunting, raising cattle and looking for wildlife with his loyal canine Dozer. He will be remembered for spending over 30 years with Phoenix Cement Plant where he retired after making many lifelong friends.<br/>
<br/>
</p>

<p>Ben’s loved ones will forever remember him as a wonderful grandfather who made great memories doting over the grandkids. He was a role model to his children, brother who loved his sisters dearly, caring uncle, and a great friend.<br/>
<br/>
</p>

<p>Ben is survived by his children Tricia (Donny) Hill and Ben (Elise) Allen, his grandchildren Briahna Hill, Coleton Hill, Avery Allen, and Logan Allen. Ben is also survived by his three sisters Mickey (Gary) Klimes, Virginia (Doug) Jones, and Barbara Morgan, along with many beloved nieces and nephews, his aunt Linda Cox, and his life-long extended family Marvin Dotson and Elaine Hess. He was preceded in death by his parents Ben C. Allen Sr., and Sylvia May Allen, and his brother-in-law Lynn Morgan.<br/>
<br/>
</p>

<p>A special thank-you to his many caregivers over the past two years including Barbie Bridge, Jadie Edwards, the Aviant Hospice team.<br/>
<br/>
</p>

<p>Please join family and friends for a casual lunch to share memories at Ben’s home on April 30 at 11:00 a.m.<br/>
<br/>
</p>

<p>Condolences may be conveyed at buelerfuneralhome.com. </p>

                <script>
  (function (d, s, n) {
      var js, fjs = d.getElementsByTagName(s)[0];
      js = d.createElement(s);
      js.className = n;
      js.src = "//player.ex.co/player/b2b663e9-f2f1-4f61-9ab5-aeaaef1357b6";
      fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'exco-player'));
</script>
<div id="b2b663e9-f2f1-4f61-9ab5-aeaaef1357b6" ></div>

                

                

                

              </div> 

            </div>

          </div> 

        </div> 

        

        









<div class="ui compact fluid six item menu story-tools">

  

  <a href="/donate/" class="item background-green has-text-white">Donate</a>

  <a href="mailto:editorial@verdenews.com?subject=TYPO: Obituary: Ben C. Allen Jr.&amp;body=Describe the typo or other error in https://verdenews.com/news/2022/apr/24/obituary-ben-c-allen-jr/" class="item background-primary-blue has-text-white">Report a Typo</a>

  <a href="/contact/" class="item">Contact</a>

  <a href="https://www.facebook.com/sharer.php?u=http://verdenews.com/news/2022/apr/24/obituary-ben-c-allen-jr/" target="new" class="item"><i class="large facebook icon"></i></a>

  <a href="http://twitter.com/home?status=http://verdenews.com/news/2022/apr/24/obituary-ben-c-allen-jr/" class="item"><i class="large twitter icon"></i></a>

  <a href="javascript:void(0)" class="item print-icon" onclick="window.print()"><i class="large print icon"></i></a>      

  

</div>




        <div class="fluid ui grey button top-margin-one-rem newsletter">Sign up for our e-News Alerts</div>



        <div class="ui grey segment most-read">

<div class="ui header">Most Read</div>

	<div class="ui top attached tabular menu">

		<div class="item active" data-tab="sevendays">7 days</div>

		<div class="item" data-tab="thirtydays">30 days</div>

	</div>

	<div class="ui bottom attached tab segment active" data-tab="sevendays">
	    <ul id="tab-content1"class="ui relaxed list">
		<li class="item"><a href="/news/2022/apr/19/strong-winds-blow-wildfire-smoke-verde-valley/">Strong winds blow wildfire smoke into Verde Valley </a></li>
		<li class="item"><a href="/news/2022/apr/20/child-services-takes-camp-verde-child-after-mother/">Child Services takes Camp Verde child after mother charged with abuse Monday </a></li>
		<li class="item"><a href="/news/2022/apr/17/police-dont-hand-money-panhandlers/">Police: Don't hand money to panhandlers </a></li>
		<li class="item"><a href="/news/2022/apr/17/house-fire-sends-2-hospital/">House fire sends 2 to hospital </a></li>
		<li class="item"><a href="/news/2022/apr/17/historic-beaver-creek-ranch-sale-after-12-years-cl/">Historic Beaver Creek Ranch for sale after 12 years of closure (VIDEO) </a></li>
		<li class="item"><a href="/news/2022/apr/20/camper-charged-felonies-accused-threatening-police/">Camper charged with felonies, accused of threatening police </a></li>
		<li class="item"><a href="/news/2022/apr/24/autopsy-suspect-y-police-shooting-shows-6-bullet-w/">Autopsy of suspect in Y-A police shooting shows 6 bullet wounds </a></li>
		<li class="item"><a href="/news/2022/apr/22/camp-verde-man-faces-felony-charges-after-shooting/">Camp Verde man faces felony charges after shooting </a></li>
		<li class="item"><a href="/news/2022/apr/20/prepare-3-year-roadwork-flex-lanes-i-17/">Prepare for 3-year roadwork, flex lanes on I-17 </a></li>
		<li class="item"><a href="/news/2022/apr/19/sgt-preston-brogdon-im-broken-not-giving/">Sgt. Preston Brogdon: ‘I'm broken but not giving up’ </a></li>
</ul>
    	</div>
    	<div class="ui bottom attached tab segment" data-tab="thirtydays">
	    <ul id="tab-content2"class="ui relaxed list">
		<li class="item"><a href="/news/2022/mar/26/prescott-bank-robbery-pursuit-ends-camp-verde-cras/">Prescott bank robbery pursuit ends in Camp Verde crash </a></li>
		<li class="item"><a href="/news/2022/apr/02/suspect-yanked-rafters-clarkdale-home/">Suspect yanked from rafters in Clarkdale home </a></li>
		<li class="item"><a href="/news/2022/apr/08/trapped-subaru-javelina-goes-ride/">Trapped in Subaru, javelina goes for a ride </a></li>
		<li class="item"><a href="/news/2022/apr/19/strong-winds-blow-wildfire-smoke-verde-valley/">Strong winds blow wildfire smoke into Verde Valley </a></li>
		<li class="item"><a href="/news/2022/mar/28/mortar-round-found-house-brings-fbi-bomb-squad/">Mortar round found in house brings in FBI, bomb squad </a></li>
		<li class="item"><a href="/news/2022/apr/20/child-services-takes-camp-verde-child-after-mother/">Child Services takes Camp Verde child after mother charged with abuse Monday </a></li>
		<li class="item"><a href="/news/2022/apr/04/sedona-robbery-suspect-fatally-shot-oklahoma-troop/">Sedona robbery suspect fatally shot by Oklahoma troopers </a></li>
		<li class="item"><a href="/news/2022/apr/17/police-dont-hand-money-panhandlers/">Police: Don't hand money to panhandlers </a></li>
		<li class="item"><a href="/news/2022/apr/11/rimrock-woman-sentenced-13-years-death-child/">Rimrock woman sentenced to 13 years in death of child </a></li>
		<li class="item"><a href="/news/2022/apr/03/cottonwood-proposes-3-annexations-along-verde-rive/">Cottonwood proposes 3 annexations along the Verde River </a></li>
</ul>
    	</div>

</div>



        <div class="ui segment has-text-centered submit-feedback">

          <h3>SUBMIT FEEDBACK</h3>

          <p>Click Below to:</p>

          <div><a href="/submit/rants-and-raves/" class="blue-link">File a Rant or Rave about this story</a></div>

          <div><a href="/contact/" class="blue-link">Ask us a question</a></div>

          <div><a href="/submit/letter-to-the-editor/" class="blue-link">Submit a letter to the editor</a></div>

          <div><a href="/contact/" class="blue-link">Send us a news tip or story idea</a></div>

        </div>        

        

        

        

        

      </div>

    </div>

    

    <div class="six wide column is-hidden-touch">

    

      <div class="right-rail">



  <div class="flex justify-center google-ads">



    



  </div>



  <div class="flex justify-center google-ads">



    



  </div>



  <div class="flex justify-center google-ads">



    



  </div>



</div> 

    

    </div>

  </div>

</div>

<div class="ui modal">

  <div class="content">

    <!-- Begin Mailchimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://westernnews.us12.list-manage.com/subscribe/post?u=ad9bbcca1da2e5673f9a3e417&amp;id=4c15ac4700" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<h2>Subscribe</h2>
<div class="indicates-required"><span class="asterisk">*</span> indicates required</div>
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address  <span class="asterisk">*</span>
</label>
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>

<div class="mc-field-group input-group">
    <strong>Websites </strong>
    <ul><li><input type="checkbox" value="1" name="group[12513][1]" id="mce-group[12513]-12513-0"><label for="mce-group[12513]-12513-0">verdenews.com</label></li>
<li><input type="checkbox" value="2" name="group[12513][2]" id="mce-group[12513]-12513-1"><label for="mce-group[12513]-12513-1">cvbugle.com</label></li>
</ul>
</div>
<div class="mc-field-group input-group">
    <strong>News </strong>
    <ul><li><input type="checkbox" value="4" name="group[13701]" id="mce-group[13701]-13701-0" checked><label for="mce-group[13701]-13701-0"> Latest Headlines</label></li>
</ul>
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_ad9bbcca1da2e5673f9a3e417_4c15ac4700" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>
<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>
<!--End mc_embed_signup-->

  </div>

</div>

<script>

document.addEventListener('click', function(e) {

  if (e.target.matches('.print-icon')) {

    window.print()

  }

}, false);

</script>



<script>

	$('.menu .item')

		.tab();

$('.ui.modal').modal('attach events', '.newsletter.button', 'show')

</script>





                

                  

                    

                  

                

              </div>

            

            

            

          

        </div> 

      

<div class="flex justify-center">

  <!-- /34608832/vvn_lb_btf -->
<div id='div-gpt-ad-1551978476607-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1551978476607-0'); });
</script>
</div>

</div>

<div class="flex justify-center bottom-mobile-leaderboard">

  <!-- /34608832/vn_mb_footer -->
<div id='div-gpt-ad-1551978748390-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1551978748390-0'); });
</script>
</div>

</div>

<div class="flex justify-center">

  <!-- /34608832/vvn_mb_footer -->
<div id='div-gpt-ad-1551978811211-0' style='height:310px; width:310px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1551978811211-0'); });
</script>
</div>

</div>



      </div> 

      

      

    

    </div> 

  </div>  

    

  <div id="main-footer" class="footer ui centered grid">

  <div class="footer__columns six column doubling row">

    <div class="footer__search three wide column has-text-centered">

      <div class="ui form">

        <form action="/search/" method="get" class="ui icon input" autocomplete="off">

          <input type="text" name="q" value="">

          <i class="search icon"></i>

        </form>

      </div>

      <div class="footer__logo">

        

          <img src="https://westernnews.media.clients.ellingtoncms.com/static-3/custom/verdenews/logos/footer-logo.png" alt="footer logo" class="ui fluid image"/>

        

      </div>

    </div>

    <div class="column">

      <div class="ui list">

        <div class="item">

          <div class="header">SECTIONS</div>

          <div class="ui divider"></div>

        </div>

        <div class="item"><a href="/news/latest-news/">News</a></div>

        <div class="item"><a href="/news/opinion/">Opinion</a></div>

        <div class="item"><a href="/news/sports/">Sports</a></div>

        <div class="item"><a href="/news/celebrate/">Celebrate</a></div>

        <div class="item"><a href="/news/kudos/">Kudos</a></div>

        <div class="item"><a href="/news/features/">Features</a></div>

        <div class="item"><a href="/news/obituaries/">Obituaries</a></div>

      </div>

    </div>

    <div class="column">

      <div class="ui list">

        <div class="item">

          <div class="header">CLASSIFIEDS</div>

          <div class="ui divider"></div>

        </div>

        <div class="item"><a href="/classifieds/">Main</a></div>

        <div class="item"><a href="/classifieds/category/employment-5003/">Jobs</a></div>

        <div class="item"><a href="/classifieds/category/transportation/">Cars</a></div>

        <div class="item"><a href="/classifieds/category/real-estate-5005/">Real Estate</a></div>

        <div class="item"><a  href="/place-classified-ad/">Place an Ad</a></div>

        <div class="item"><a href="/about/">About Us</a></div>

        <div class="item"><a href="/contact/">Contact Us</a></div>

      </div>

    </div>

    

    <div class="column">

      <div class="ui list">

        <div class="item">

          <div class="header">SUBMISSIONS</div>

          <div class="ui divider"></div>

        </div>

        <div class="item"><a href="/contact/">Submit a News Tip</a></div>

        <div class="item"><a href="/submit/birth-announcement/">Birth</a></div>

        <div class="item"><a href="/submit/engagement-wedding-announcement/">Wedding <br> Engagement</a></div>

        <div class="item"><a href="/submit/anniversary/">Anniversary</a></div>

        <div class="item"><a href="/contact/">Website Feedback</a></div>

        <div class="item"><a href="/subscriber-services/index/">Subscriber Services</a></div>

      </div>

    </div>

  </div>

  <div class="one column row">

    <div class='copyright'>

      

        <p class="has-text-white"><span>Contents of this site are &copy; Copyright 2022 The Verde Independent and Western News&amp;Info&reg;, Inc. All rights reserved. | </span><a href="/terms-of-service/" class="has-text-white"> Terms of Service</a> | <a href="/privacy-policy/" class="has-text-white">Privacy Policy</a></p>

      

    </div>

  </div>

</div>



  

<script>

	$('.menu .item')

		.tab();

$('.ui.modal').modal('attach events', '.newsletter.button', 'show')

</script>



    

  <script src="https://cdn.syncronex.com/libs/v1.9/syncLoginSdk.js"></script>

  <script>

    var SYNCRONEX_DOMAIN = 'https://subscribe.verdenews.com'

    function setView (status) {

      var login = document.getElementById('sync-login-status');

      var mobileSubscribe = document.getElementById('mobile-subscribe');

      var myaccount = document.getElementById('sync-login-myaccount');

      var logout = document.getElementById('btnLogout');

      var logoutContainer = document.getElementById('logoutContainer');

      var subscribeNow = document.getElementById('subscribe-now');

      if (status === 'loggedIn') {

        myaccount.textContent = ' My Account';

        myaccount.href = "https://iservicescirc.westernnews.com/cgi-bin/cmo_cmo.sh/custservice/web/login.html?siteid=VVN";

        login.style.display = 'none';

        mobileSubscribe.style.display = 'none';

      } else if (status === "notLoggedIn") {

        subscribeNow.style.display = 'inline-block';

        myaccount.style.display = 'none';

        logoutContainer.style.display = 'none';

        login.href = SYNCRONEX_DOMAIN + "/wn/vvn/account/logon?ReturnUrl=https://www.verdenews.com/syncronex_redirect/news/2022/apr/24/obituary-ben-c-allen-jr/";

        login.target = "_self";

        login.textContent = ' Login';

      }

    }

    var sdk = window.syncLoginSdk;

    //sdk.applicationOrigin = 'https://subscribe.verdenews.com';

    sdk.applicationOrigin = SYNCRONEX_DOMAIN;

    sdk.debug = true;

    sdk.apiTimeout = 5000;

    sdk.sessionExpireDays = 30;

    sdk.requireLegacyLogin = true;

    sdk.tenantId = 'wn-vvn';

    // getLoginStatus takes two parameters - the first is a success callback, the second is a failure callback

    var url = "/set_sync_id/";

    

    var isAuthenticated = false;

    console.log('is authenticated?',isAuthenticated)

    $(document).ready(function(){

      sdk.getLoginStatus(function (data) {

	      // console.log(data);

        var payload = {}

        payload.syncronex_id = data.userid

        payload.email = data.email

        payload.csrfmiddlewaretoken = "jAMrzzLbFIZXWiWzcz43B8Kk3MvrsR6v";

        // console.log(payload);

        if (!isAuthenticated){

          $.post(url, payload, function(data){

            if (typeof(SYNCRONEX_NEXT_URL)=="undefined") {

              // window.location.reload();

            } else {

              setTimeout(function() { window.location.href = SYNCRONEX_NEXT_URL }, 250);

            }

          });

        } else {

            setView("loggedIn");

        }

      }, function (errStatus) {

	        setView("notLoggedIn")

        });

    });

    var btnLogout = document.getElementById('btnLogout');

    btnLogout.addEventListener('click', function(e) {

      sdk.logOut(function() {

        window.location.href = "/accounts/logout/";

      }, function() {

        alert('Log out failed.');

      });

    })

  </script>



  <script>

    $('.ui.sidebar-nav')

    .sidebar('attach events', '.show-side-nav-button');

    $('.top-more-menu')

    .sidebar({

      transition: 'push',

    })

    .sidebar('attach events', 'div.more-menu');

  </script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/linkify.min.js?v=7"></script>  

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/linkify-jquery.min.js?v=8"></script>

  <script>

     // turn plain text links into hyperlinks

    $('p').linkify();

    $('div').linkify();

    $('#sidebar').linkify({

      target: "_blank"

    });

  </script>

  <script type="text/javascript" src="https://westernnews.media.clients.ellingtoncms.com/static-3/javascript/westernnews.js?v=18" async></script>

</body>

</html>
